// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https?:\/\/(m\.)?vk\.com\/((club|public)(\d+)|[_.a-zA-Z0-9]{5,32})?(\?w=)?wall(-\d+)_(\d+)$").unwrap();
let string = "https://vk.com/club
https://vk.com/id
https://vk.com/id123
https://vk.com/club213560530
https://m.vk.com/club213560530
https://m.vk.com/club213560530
https://vk.com/ps4exploit?w=wall-212141395_852
https://vk.com/wall-212141395_852
https://vk.com/wall-212141395_
https://vk.com/wall1_1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}