using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-(?!\().+\)$";
string input = @"@addle-head /'ædlhed/ (addle-pate) /'ædlpeit/
-pate)
/'ædlpeit/
* danh từ
- người đầu óc lẫn quẫn";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}