re = /^-(?!\().+\)$/m
str = '@addle-head /\'ædlhed/ (addle-pate) /\'ædlpeit/
-pate)
/\'ædlpeit/
* danh từ
- người đầu óc lẫn quẫn'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end