use strict;
my $str = 'Module([Assign([Name(\'a\', Store())], Num(2)), Assign([Name(\'b\', Store())], Num(3)), Assign([Name(\'c\', Store())], Str(\'Hello\')), Assign([Name(\'x\', Store())], BinOp(Name(\'a\', Load()), Add(), Name(\'b\', Load()))), Assign([Name(\'x\', Store())], Name(\'a\', Load())), Expr(Call(Name(\'print\', Load()), [Name(\'a\', Load())], [], None, None)), For(Name(\'i\', Store()), Call(Name(\'range\', Load()), [Num(10)], [], None, None), [Expr(Call(Name(\'print\', Load()), [Name(\'a\', Load())], [], None, None))], [])])';
my $regex = qr/(?<!Call\(Name\(')\b\w+\b(?=', Load)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}