re = /(?<!Call\(Name\(')\b\w+\b(?=', Load)/
str = 'Module([Assign([Name(\'a\', Store())], Num(2)), Assign([Name(\'b\', Store())], Num(3)), Assign([Name(\'c\', Store())], Str(\'Hello\')), Assign([Name(\'x\', Store())], BinOp(Name(\'a\', Load()), Add(), Name(\'b\', Load()))), Assign([Name(\'x\', Store())], Name(\'a\', Load())), Expr(Call(Name(\'print\', Load()), [Name(\'a\', Load())], [], None, None)), For(Name(\'i\', Store()), Call(Name(\'range\', Load()), [Num(10)], [], None, None), [Expr(Call(Name(\'print\', Load()), [Name(\'a\', Load())], [], None, None))], [])])'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end