using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(20\d{2}).(\d{1,2}).(\d{1,2})";
string input = @"2020.01.01.
2020.2.28
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}