package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(20\d{2}).(\d{1,2}).(\d{1,2})`)
var str = `2020.01.01.
2020.2.28
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}