using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\\)(4[0-9]*)_([0-9]*)\\[^\\]+\.\w+";
string input = @"\subpath1\subpath2\subpathn\40000_21234\filename.extension";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}