const regex = new RegExp('(?<=\\\\)(4[0-9]*)_([0-9]*)\\\\[^\\\\]+\\.\\w+', 'gm')
const str = `\\subpath1\\subpath2\\subpathn\\40000_21234\\filename.extension`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}