re = /(?<=\\)(4[0-9]*)_([0-9]*)\\[^\\]+\.\w+/m
str = '\\subpath1\\subpath2\\subpathn\\40000_21234\\filename.extension'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end