# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?!^|$)|\W\K(?=\W)/ /g;t' <<< "(5+4+8+5)+(5^2/(23%2))"