$re = '/\b(?!^|$)|\W\K(?=\W)/';
$str = '(5+4+8+5)+(5^2/(23%2))';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;