const regex = /\b(?!^|$)|\W\K(?=\W)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!^|$)|\\W\\K(?=\\W)', 'g')
const str = `(5+4+8+5)+(5^2/(23%2))`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);