const regex = /(?<=-)\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=-)\\n', 'gm')
const str = `This is a ice-
cream and this is a car `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);