use strict;
my $str = 'This is a ice-
cream and this is a car ';
my $regex = qr/(?<=-)\n/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";