$re = '/(?<=-)\n/m';
$str = 'This is a ice-
cream and this is a car ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;