#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[([A-Za-z0-9_][♤♡♢♧]?,\s*[A-Za-z0-9_][♤♡♢♧]?)]"
Local $sString = "Player (8, 5) won the $5.40 main pot with a Straight" & @CRLF & _
"Player (A, 2) won the $21.00 main pot with a flush" & @CRLF & _
" $100.01', 'dd $1,000.05', " & @CRLF & _
" 'f 10,000', 'g 100,000'," & @CRLF & _
" 'yr 4,120,000.65" & @CRLF & _
"" & @CRLF & _
"Action" & @CRLF & _
"Player[J♡, K♧] won the $5.40 main pot with a Straight" & @CRLF & _
"Player [5, 2] won the $21.00 main pot with a flush"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")