re = /\[([A-Za-z0-9_][♤♡♢♧]?,\s*[A-Za-z0-9_][♤♡♢♧]?)]/m
str = 'Player (8, 5) won the $5.40 main pot with a Straight
Player (A, 2) won the $21.00 main pot with a flush
$100.01\', \'dd $1,000.05\',
\'f 10,000\', \'g 100,000\',
\'yr 4,120,000.65
Action
Player[J♡, K♧] won the $5.40 main pot with a Straight
Player [5, 2] won the $21.00 main pot with a flush'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end