const regex = new RegExp('\\[([A-Za-z0-9_][♤♡♢♧]?,\\s*[A-Za-z0-9_][♤♡♢♧]?)]', 'gm')
const str = `Player (8, 5) won the \$5.40 main pot with a Straight
Player (A, 2) won the \$21.00 main pot with a flush
\$100.01', 'dd \$1,000.05',
'f 10,000', 'g 100,000',
'yr 4,120,000.65
Action
Player[J♡, K♧] won the \$5.40 main pot with a Straight
Player [5, 2] won the \$21.00 main pot with a flush`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}