package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^@]+@){2}[^.]+\.[a-z]+$`)
var str = `fisrt@last@email.com
match@me@email.com
dont@matchme.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}