re = /^(?:[^@]+@){2}[^.]+\.[a-z]+$/m
str = 'fisrt@last@email.com
match@me@email.com
dont@matchme.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end