$re = '/^(?:[^@]+@){2}[^.]+\.[a-z]+$/m';
$str = 'fisrt@last@email.com
match@me@email.com
dont@matchme.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);