#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:[01][0-9]?)|(?:2[0-4]?)|(?:[3-9]))(?::((?:[0-5][0-9]?)|(?:60))|:)?$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"12" & @CRLF & _
"12:" & @CRLF & _
"12:3" & @CRLF & _
"12:30" & @CRLF & _
"1:" & @CRLF & _
"1:3" & @CRLF & _
"1:30" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"4" & @CRLF & _
"5" & @CRLF & _
"6" & @CRLF & _
"7" & @CRLF & _
"8" & @CRLF & _
"9" & @CRLF & _
"1:60" & @CRLF & _
"24:60" & @CRLF & _
"24:00" & @CRLF & _
"00:60" & @CRLF & _
"" & @CRLF & _
"25:30" & @CRLF & _
"00:61"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")