re = /^((?:[01][0-9]?)|(?:2[0-4]?)|(?:[3-9]))(?::((?:[0-5][0-9]?)|(?:60))|:)?$/m
str = '0
1
12
12:
12:3
12:30
1:
1:3
1:30
2
3
4
5
6
7
8
9
1:60
24:60
24:00
00:60
25:30
00:61'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end