import re
regex = re.compile(r"^((?:[01][0-9]?)|(?:2[0-4]?)|(?:[3-9]))(?::((?:[0-5][0-9]?)|(?:60))|:)?$", flags=re.MULTILINE)
test_str = ("0\n"
"1\n"
"12\n"
"12:\n"
"12:3\n"
"12:30\n"
"1:\n"
"1:3\n"
"1:30\n"
"2\n"
"3\n"
"4\n"
"5\n"
"6\n"
"7\n"
"8\n"
"9\n"
"1:60\n"
"24:60\n"
"24:00\n"
"00:60\n\n"
"25:30\n"
"00:61")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")