#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)type\s*=\s*['"]?application\/rss\+xml[^>]+href\s*=\s*['"]?([^'"]*)['"]?|href\s*=\s*['"]?([^"']*)['"]?[^>]+type\s*=\s*['"]?application\/rss\+xml['"]?"
Local $sString = "<link rel='dns-prefetch' href='//code.tidio.co' />" & @CRLF & _
"<link rel='dns-prefetch' href='//fonts.googleapis.com' />" & @CRLF & _
"<link rel='dns-prefetch' href='//s.w.org' />" & @CRLF & _
"<link rel="alternate" type="application/rss+xml" title="Zrce.eu » Feed" href="https://zrce.eu/feed/" />" & @CRLF & _
"<link rel="alternate" type="application/rss+xml" title="Zrce.eu » Kommentar-Feed" href="https://zrce.eu/comments/feed/" />" & @CRLF & _
" <script type="text/javascript">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")