import re
regex = re.compile(r"(?i)type\s*=\s*['\"]?application\/rss\+xml[^>]+href\s*=\s*['\"]?([^'\"]*)['\"]?|href\s*=\s*['\"]?([^\"']*)['\"]?[^>]+type\s*=\s*['\"]?application\/rss\+xml['\"]?")
test_str = ("<link rel='dns-prefetch' href='//code.tidio.co' />\n"
"<link rel='dns-prefetch' href='//fonts.googleapis.com' />\n"
"<link rel='dns-prefetch' href='//s.w.org' />\n"
"<link rel=\"alternate\" type=\"application/rss+xml\" title=\"Zrce.eu » Feed\" href=\"https://zrce.eu/feed/\" />\n"
"<link rel=\"alternate\" type=\"application/rss+xml\" title=\"Zrce.eu » Kommentar-Feed\" href=\"https://zrce.eu/comments/feed/\" />\n"
" <script type=\"text/javascript\">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")