$re = '/(?i)type\s*=\s*[\'"]?application\/rss\+xml[^>]+href\s*=\s*[\'"]?([^\'"]*)[\'"]?|href\s*=\s*[\'"]?([^"\']*)[\'"]?[^>]+type\s*=\s*[\'"]?application\/rss\+xml[\'"]?/';
$str = '<link rel=\'dns-prefetch\' href=\'//code.tidio.co\' />
<link rel=\'dns-prefetch\' href=\'//fonts.googleapis.com\' />
<link rel=\'dns-prefetch\' href=\'//s.w.org\' />
<link rel="alternate" type="application/rss+xml" title="Zrce.eu » Feed" href="https://zrce.eu/feed/" />
<link rel="alternate" type="application/rss+xml" title="Zrce.eu » Kommentar-Feed" href="https://zrce.eu/comments/feed/" />
<script type="text/javascript">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);