#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bb?a(ba)*\b"
Local $sString = "подходило под:" & @CRLF & _
"a" & @CRLF & _
"ababa" & @CRLF & _
"babababa" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"и не подхоило под:" & @CRLF & _
"aa" & @CRLF & _
"abaa" & @CRLF & _
"babbab" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")