$re = '/\bb?a(ba)*\b/m';
$str = 'подходило под:
a
ababa
babababa
и не подхоило под:
aa
abaa
babbab
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);