package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bb?a(ba)*\b`)
var str = `подходило под:
a
ababa
babababa
и не подхоило под:
aa
abaa
babbab
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}