import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|(\\d*) *(\\b[a-z]+(?: [a-z]+)*?)(?= and )|(?<= and )(\\d*) *(\\b[a-z]+(?: [a-z]+)*))";
final String string = "2 Better Developers and 3 Testers\n"
+ "5 Mechanics and chef\n"
+ "medic and 3 nurses\n"
+ "5 Mechanics and 2 chefs and tester\n"
+ "5 foo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}