const regex = /(?|(\d*) *(\b[a-z]+(?: [a-z]+)*?)(?= and )|(?<= and )(\d*) *(\b[a-z]+(?: [a-z]+)*))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|(\\d*) *(\\b[a-z]+(?: [a-z]+)*?)(?= and )|(?<= and )(\\d*) *(\\b[a-z]+(?: [a-z]+)*))', 'gmi')
const str = `2 Better Developers and 3 Testers
5 Mechanics and chef
medic and 3 nurses
5 Mechanics and 2 chefs and tester
5 foo`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}