$re = '/(?|(\d*) *(\b[a-z]+(?: [a-z]+)*?)(?= and )|(?<= and )(\d*) *(\b[a-z]+(?: [a-z]+)*))/mi';
$str = '2 Better Developers and 3 Testers
5 Mechanics and chef
medic and 3 nurses
5 Mechanics and 2 chefs and tester
5 foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);