#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?foo.*?foo.*?)foo"
Local $sString = "foo bar bash 1 foo dash mesh 3 foo poly 3 for foo" & @CRLF & _
"foo tar hash 1 foo gash gesh 3 foo toly 3 vor foo" & @CRLF & _
"foo sar wash 1 foo rash nesh 3 foo koly 3 sor foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")