import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?foo.*?foo.*?)foo";
final String string = "foo bar bash 1 foo dash mesh 3 foo poly 3 for foo\n"
+ "foo tar hash 1 foo gash gesh 3 foo toly 3 vor foo\n"
+ "foo sar wash 1 foo rash nesh 3 foo koly 3 sor foo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}