re = /^(.*?foo.*?foo.*?)foo/m
str = 'foo bar bash 1 foo dash mesh 3 foo poly 3 for foo
foo tar hash 1 foo gash gesh 3 foo toly 3 vor foo
foo sar wash 1 foo rash nesh 3 foo koly 3 sor foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end