using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Local[ \t]+(\w+)[ \t]+=";
string substitution = @"int $1 =";
string input = @"
//Сколько игроков
Local PlayerNum = 1;
Local tLevel Lvl = tLevel.Get(LvlName);
Local UpdMods = 0;
Local Box hm= new Box();
Local x => int x";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}