#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w*?\.(#+)(\.\w*?)*?$"
Local $sString = "bob.#" & @CRLF & _
"bob.#." & @CRLF & _
"bob.#.exr" & @CRLF & _
"bob.##.mary.tif" & @CRLF & _
"bob.####.png" & @CRLF & _
"" & @CRLF & _
"bob.#string.exr" & @CRLF & _
"bob.string#.exr" & @CRLF & _
"" & @CRLF & _
"bob.string.exr" & @CRLF & _
"bob..exr" & @CRLF & _
"" & @CRLF & _
"bob.#. more" & @CRLF & _
"more bob.#."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")