re = /^\w*?\.(#+)(\.\w*?)*?$/m
str = 'bob.#
bob.#.
bob.#.exr
bob.##.mary.tif
bob.####.png
bob.#string.exr
bob.string#.exr
bob.string.exr
bob..exr
bob.#. more
more bob.#.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end