using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w*?\.(#+)(\.\w*?)*?$";
string input = @"bob.#
bob.#.
bob.#.exr
bob.##.mary.tif
bob.####.png
bob.#string.exr
bob.string#.exr
bob.string.exr
bob..exr
bob.#. more
more bob.#.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}