$re = '/https:\/\/(\S*)\/(\S*)\//m';
$str = 'https://mysite.ru/rostov-na-donu/products
https://mysite.ru/Ростове-на-Дону/products';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);