re = /https:\/\/(\S*)\/(\S*)\//m
str = 'https://mysite.ru/rostov-na-donu/products
https://mysite.ru/Ростове-на-Дону/products'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end