package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https:\/\/www\.waze\.com\/ul\?.*?ll\=(\d+\.\d+)%2C-(\d+\.\d+)`)
var str = `https://www.waze.com/ul?place=ChIJj61dQgK6j4AR4GeTYWZsKWw&ll=37.42199990%2C-122.08405750&navigate=yes
https://www.waze.com/ul?ll=40.75793646%2C-73.99360657&navigate=yes&zoom=16`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}