re = /https:\/\/www\.waze\.com\/ul\?.*?ll\=(\d+\.\d+)%2C-(\d+\.\d+)/m
str = 'https://www.waze.com/ul?place=ChIJj61dQgK6j4AR4GeTYWZsKWw&ll=37.42199990%2C-122.08405750&navigate=yes
https://www.waze.com/ul?ll=40.75793646%2C-73.99360657&navigate=yes&zoom=16'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end