const regex = /https:\/\/www\.waze\.com\/ul\?.*?ll\=(\d+\.\d+)%2C-(\d+\.\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/www\\.waze\\.com\\\/ul\\?.*?ll\\=(\\d+\\.\\d+)%2C-(\\d+\\.\\d+)', 'gm')
const str = `https://www.waze.com/ul?place=ChIJj61dQgK6j4AR4GeTYWZsKWw&ll=37.42199990%2C-122.08405750&navigate=yes
https://www.waze.com/ul?ll=40.75793646%2C-73.99360657&navigate=yes&zoom=16`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}