#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)commer.{1,5} autour"
Local $sString = "[NE PAS PRENDRE EN COMPTE]" & @CRLF & _
"----------------------------------------------------------" & @CRLF & _
"-> R1: environnement (\w{1,5}\s)?comme" & @CRLF & _
"environnement commercial : boulangerie, supérette, boucherie, coiffeur" & @CRLF & _
"environnement de commerces de proximités (pharmacie,boucherie, boulangerie)" & @CRLF & _
"environnement commerçant (pharmacie, boulangerie, boucherie)" & @CRLF & _
"environnement commerçant composé de : nicolas, paul, boucherie" & @CRLF & _
"" & @CRLF & _
"--------------------------------" & @CRLF & _
"-> R2: enseignes?" & @CRLF & _
"enseignes telles que boulangerie ange, picard, boucherie dubocage et biocoop" & @CRLF & _
"(enseignes : intersport, v&b, picard, marie blachere, pizza, boucherie)" & @CRLF & _
"" & @CRLF & _
"--------------------------------" & @CRLF & _
"-> R3: (voisinage|entour[ée]e)" & @CRLF & _
"entourée d'une pizzeria, coiffeur, bar/tabac/presse, boucherie" & @CRLF & _
"au voisinage, entre autre : restauration rapide, boucherie, vin et liqueur" & @CRLF & _
"voisinage : casino supermarché , burger king, la boucherie" & @CRLF & _
"" & @CRLF & _
"--------------------------------" & @CRLF & _
"-> R4 :" & @CRLF & _
"commodités tout autour (boulangerie pâtisserie, , coiffeurs)" & @CRLF & _
"proximité de commerces tels que : le cic, franprix, boucherie" & @CRLF & _
"" & @CRLF & _
"--------------------------------" & @CRLF & _
"-> R5 :comm.* (de|à) proximit[ée]" & @CRLF & _
"commerces de proximité déjà installés : pharmacie, bar-tabac, boucherie" & @CRLF & _
"commerces de proximité juste à coté : restaurants,boucherie" & @CRLF & _
"" & @CRLF & _
"--------------------------------" & @CRLF & _
"-> R6 : (secteur|p[oô]le|zone|rue|centre) commer.{1,5}" & @CRLF & _
"proche rue commerçante (boulangerie, boucherie)" & @CRLF & _
"près d'une pole commercial composé de boulangeries, boucheries" & @CRLF & _
"dans une zone commerciale constitué boulangerie, boucherie" & @CRLF & _
"dans secteur commercial, boulangerie, boucherie" & @CRLF & _
"situé à l'arrière d'un centre commercial : garage auto, boucherie" & @CRLF & _
"" & @CRLF & _
"--------------------------------" & @CRLF & _
"-> R7 : activit[eé]s (non autoris[eé]e?s?|interdites|exclue?s?)" & @CRLF & _
"activités non autorisées : - restauration (pas d'extraction) et boucherie" & @CRLF & _
"activités interdites : commerce de bouche, boucherie" & @CRLF & _
"activités exclues : commerce de bouche, boucherie" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"--------------------------------" & @CRLF & _
"-> R8 :" & @CRLF & _
"commerces autour : agence immobilière, boulangerie, boucherie" & @CRLF & _
"très bel emplacement, boucherie charcuterie traiteur" & @CRLF & _
"" & @CRLF & _
"--------------------------------" & @CRLF & _
"-> R9 :[aà] (c[oô]té|proximité|autour)" & @CRLF & _
"boucherie charcuterie traiteur autour" & @CRLF & _
"supermarché g20, boucherie à proximité" & @CRLF & _
"supermarché g20, boucherie, boulangerie à côté" & @CRLF & _
"commerces de proximité juste à coté : restaurants,boucherie" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"on y trouve aussi des commerces de proximité, boulangeries" & @CRLF & _
"disposant de nombreux commerces," & @CRLF & _
"nombreuses offres de restaurations " & @CRLF & _
"proche toutes commodités :" & @CRLF & _
"tous types d'activité à l'exception de boulangerie, boucherie" & @CRLF & _
"services sont à la disposition des utilisateurs :" & @CRLF & _
"centre ville se prête à toutes activités, boulangerie, boucherie" & @CRLF & _
"rue de boucheries " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")