use strict;
my $str = '[NE PAS PRENDRE EN COMPTE]
----------------------------------------------------------
-> R1: environnement (\\w{1,5}\\s)?comme
environnement commercial : boulangerie, supérette, boucherie, coiffeur
environnement de commerces de proximités (pharmacie,boucherie, boulangerie)
environnement commerçant (pharmacie, boulangerie, boucherie)
environnement commerçant composé de : nicolas, paul, boucherie
--------------------------------
-> R2: enseignes?
enseignes telles que boulangerie ange, picard, boucherie dubocage et biocoop
(enseignes : intersport, v&b, picard, marie blachere, pizza, boucherie)
--------------------------------
-> R3: (voisinage|entour[ée]e)
entourée d\'une pizzeria, coiffeur, bar/tabac/presse, boucherie
au voisinage, entre autre : restauration rapide, boucherie, vin et liqueur
voisinage : casino supermarché , burger king, la boucherie
--------------------------------
-> R4 :
commodités tout autour (boulangerie pâtisserie, , coiffeurs)
proximité de commerces tels que : le cic, franprix, boucherie
--------------------------------
-> R5 :comm.* (de|à) proximit[ée]
commerces de proximité déjà installés : pharmacie, bar-tabac, boucherie
commerces de proximité juste à coté : restaurants,boucherie
--------------------------------
-> R6 : (secteur|p[oô]le|zone|rue|centre) commer.{1,5}
proche rue commerçante (boulangerie, boucherie)
près d\'une pole commercial composé de boulangeries, boucheries
dans une zone commerciale constitué boulangerie, boucherie
dans secteur commercial, boulangerie, boucherie
situé à l\'arrière d\'un centre commercial : garage auto, boucherie
--------------------------------
-> R7 : activit[eé]s (non autoris[eé]e?s?|interdites|exclue?s?)
activités non autorisées : - restauration (pas d\'extraction) et boucherie
activités interdites : commerce de bouche, boucherie
activités exclues : commerce de bouche, boucherie
--------------------------------
-> R8 :
commerces autour : agence immobilière, boulangerie, boucherie
très bel emplacement, boucherie charcuterie traiteur
--------------------------------
-> R9 :[aà] (c[oô]té|proximité|autour)
boucherie charcuterie traiteur autour
supermarché g20, boucherie à proximité
supermarché g20, boucherie, boulangerie à côté
commerces de proximité juste à coté : restaurants,boucherie
on y trouve aussi des commerces de proximité, boulangeries
disposant de nombreux commerces,
nombreuses offres de restaurations
proche toutes commodités :
tous types d\'activité à l\'exception de boulangerie, boucherie
services sont à la disposition des utilisateurs :
centre ville se prête à toutes activités, boulangerie, boucherie
rue de boucheries
';
my $regex = qr/commer.{1,5} autour/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}