import re
regex = re.compile(r"commer.{1,5} autour", flags=re.MULTILINE)
test_str = ("[NE PAS PRENDRE EN COMPTE]\n"
"----------------------------------------------------------\n"
"-> R1: environnement (\\w{1,5}\\s)?comme\n"
"environnement commercial : boulangerie, supérette, boucherie, coiffeur\n"
"environnement de commerces de proximités (pharmacie,boucherie, boulangerie)\n"
"environnement commerçant (pharmacie, boulangerie, boucherie)\n"
"environnement commerçant composé de : nicolas, paul, boucherie\n\n"
"--------------------------------\n"
"-> R2: enseignes?\n"
"enseignes telles que boulangerie ange, picard, boucherie dubocage et biocoop\n"
"(enseignes : intersport, v&b, picard, marie blachere, pizza, boucherie)\n\n"
"--------------------------------\n"
"-> R3: (voisinage|entour[ée]e)\n"
"entourée d'une pizzeria, coiffeur, bar/tabac/presse, boucherie\n"
"au voisinage, entre autre : restauration rapide, boucherie, vin et liqueur\n"
"voisinage : casino supermarché , burger king, la boucherie\n\n"
"--------------------------------\n"
"-> R4 :\n"
"commodités tout autour (boulangerie pâtisserie, , coiffeurs)\n"
"proximité de commerces tels que : le cic, franprix, boucherie\n\n"
"--------------------------------\n"
"-> R5 :comm.* (de|à) proximit[ée]\n"
"commerces de proximité déjà installés : pharmacie, bar-tabac, boucherie\n"
"commerces de proximité juste à coté : restaurants,boucherie\n\n"
"--------------------------------\n"
"-> R6 : (secteur|p[oô]le|zone|rue|centre) commer.{1,5}\n"
"proche rue commerçante (boulangerie, boucherie)\n"
"près d'une pole commercial composé de boulangeries, boucheries\n"
"dans une zone commerciale constitué boulangerie, boucherie\n"
"dans secteur commercial, boulangerie, boucherie\n"
"situé à l'arrière d'un centre commercial : garage auto, boucherie\n\n"
"--------------------------------\n"
"-> R7 : activit[eé]s (non autoris[eé]e?s?|interdites|exclue?s?)\n"
"activités non autorisées : - restauration (pas d'extraction) et boucherie\n"
"activités interdites : commerce de bouche, boucherie\n"
"activités exclues : commerce de bouche, boucherie\n\n\n"
"--------------------------------\n"
"-> R8 :\n"
"commerces autour : agence immobilière, boulangerie, boucherie\n"
"très bel emplacement, boucherie charcuterie traiteur\n\n"
"--------------------------------\n"
"-> R9 :[aà] (c[oô]té|proximité|autour)\n"
"boucherie charcuterie traiteur autour\n"
"supermarché g20, boucherie à proximité\n"
"supermarché g20, boucherie, boulangerie à côté\n"
"commerces de proximité juste à coté : restaurants,boucherie\n\n\n"
"on y trouve aussi des commerces de proximité, boulangeries\n"
"disposant de nombreux commerces,\n"
"nombreuses offres de restaurations \n"
"proche toutes commodités :\n"
"tous types d'activité à l'exception de boulangerie, boucherie\n"
"services sont à la disposition des utilisateurs :\n"
"centre ville se prête à toutes activités, boulangerie, boucherie\n"
"rue de boucheries \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")