using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![A-Z0-9])[A-Z0-9]{7}(?![A-Z0-9])";
string input = @"LTE_LTE_FSD9167__P_Airport1
RUR1251__S_KhooNaiWala";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}